WorldWideScripts.net Delivering the best Add-Ons in more than 37 languages.

中文(简体), English, हिन्दी/हिंदी, Español/Castellano, العربية, Русский язык, Français, 中文 (台灣), বাংলা, Bahasa Indonesia, اردو, Português, Deutsch, Bahasa Melayu (بهاس ملايو‎), 日本語 (にほんご), فارسی, Italiano, తెలుగు, Türkçe, ગુજરાતી, Język polski/polszczyzna, Tiếng Việt, ಕನ್ನಡ, Українська мова, ไทย
PHP Scripts / Miscellaneous

Advanced PHP Protection

— Add-On para WorldWideScripts.net

@pt1wwsAssine o nosso feed para se manter atualizado!

Novo! Siga-nos o que você quiser!


Advanced PHP Protection - CodeCanyon Item for Sale

Ads

Ad: Bluehost hosting
Principais Características:
  • Funciona com qualquer.php.
  • Senha personalizada e páginas de aviso de força bruta.
  • Funções bem documentado.
  • Pode facilmente ser integrados em um banco de dados criado com múltiplos usuários.
  • Modo de linha única, proteger qualquer página simplesmente incluindo o arquivo.
  • Senhas podem ser definidas como qualquer um md5 de hash SHA1 ou texto simples, se você preferir.
  • Do lado do servidor proteção da força bruta, com opções para alterar o número máximo de tentativas e duração do bloco.
  • No banco de dados ou instalação necessária.
  • Apoio e-mail fornecido.
  • O peso leve.

NOTA: A sessão é usado para armazenar o nome de usuário e senha para que você não precisa fazer o login novamente quando a página é recarregada. As variáveis ​​$ _SESSION [â € ~usernameâ ™ €] e $ _SESSION função [â € ~passwordâ € ™] são usados ​​por padrão, se você precisar usá-los no script sendo protegido você pode definir nomes personalizados usando as custom_session_keys (), consulte a documentação para obter mais informações.



Exemplo Uso:
Modo padrão

 include ('seguro / security.class.inc.php'); $ Passe = new seguro; // Definir o nome de usuário e senha, neste caso, como um hash SHA1 $ Senhas> set_credentials ('admin', '5baa61e4c9b93f3f0682250b6cf8331b7ee68fd8'); // Definir o tipo de hash $-Passe> set_hash_type ('sha1'); // Definir algumas chaves de sessão personalizada $ Senhas> custom_session_keys ('nome', 'pass'); // Habilitar a proteção de força bruta, desativada por padrão. $-Passe> brute_force_protect (); // Configura uma página personalizada para o usuário para ser enviado para que a senha que entrou incorretamente. $-Passe> redirect_on_fail ('http://yourdomain.com/denied.html'); // Finalmente aplicar a proteção à página. $-Passe> proteger (); echo 'conteúdos protegidos aqui.'; 


Modo Linha

 include ('seguro / security.class.inc.php'); echo "conteúdo protegido aqui. ' 


Documentação: http://jacekk.co.uk/code/page_protect/README.html

Exemplo da página de login incluído
http://jacekk.co.uk/code/page_protect/example.php
Nome de usuário: admin
Password: limão


NOTA: este script só irá funcionar se você tiver a versão PHP maior do que 5,1. Eu tive alguns e-mails de pessoas que se queixam de uma página em branco que estavam usando PHP4. Você pode conferir-lhe a versão usando o seguinte código.
 <? Php echo phpversion (); ?> 

I don € ™ t quer que ninguém a desperdiçar o seu dinheiro.

Apoio
Se houver algum problema com este item, o melhor lugar para perguntar é no fórum como eu verificar que pelo menos uma vez por dia.
http://betterphp.co.uk/board/viewforum.php?f=29

Download
Outros componentes nesta categoriaTodos os componentes deste autor
ComentáriosPerguntas mais frequentes perguntas e respostas

Propriedades

Criado:
27 10 de abril

Última Atualização:
N / A

Navegadores compatíveis:
IE6, IE7, IE8, Firefox, Safari, Opera, Chrome 4, Chrome 5

Arquivos incluídos:
JavaScript JS, HTML, CSS, PHP

Software Version:
PHP 5.x

Palavras-chave

eCommerce, todos os itens, auth, autenticaç, ã, o, forç, a bruta, a senha, prevenç, ã, o, proteç, ã, o, roteiro, garantir